Tuesday, March 27, 2012

App could not be installed in the itunes library because it is not a valid Application

Hi all
For those who stuck up with the error stated above “ App could not be installed in the iTunes library because it is not a valid application”. Here is the simple and correct solution. Finding out the solution, you will be astonished thinking that how would a auto run if someone turns the rear view mirror. But, it works. Go to project target and in summary, you will find two parameters to be filled.
  1. Version
  2. Build
If any one of these parameters is left empty and if you try creating an iPa, you can successfully create an iPa but while syncing to iTunes you will get an error message stating “App could not be installed in the iTunes library because it is not a valid application.” Most probably your version will be filled and Build will be empty. Give some value to it. Build an iPa.

Bingo.

No comments:

Post a Comment

Share it if you like it